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Gauging ADF Application Performance: 
 Instrumenting Your Code 

Presented by: John Jay King 
Download this paper from: 
 http://www.kingtraining.com 



2 
Copyright @ 2015, John Jay King 

Session Objectives 

•  Learn how Oracle and Oracle WebLogic 
server support tuning instrumentation 

•  Be able to instrument ADF to track 
performance 

•  Use performance tracking data to improve 
ADF application performance  
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Who Am I? 

•  John King – Partner, King Training Resources 

•  Oracle Ace Director 

•  Member Oak Table Network 

•  Providing training to Oracle and IT community for 
over 25 years – http://www.kingtraining.com 

•  “Techie” who knows Oracle, ADF, SQL, Java,  
and PL/SQL pretty well (along with other topics) 

•  Member of AZORA, ODTUG, IOUG, and RMOUG 
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Planes Have Instruments: Why? 
•  Most of us have been aircraft passengers 

(probably recently) 
– Aren’t you glad the plane’s crew had 

instruments to monitor things? 
– Would you trade the cost/complexity of the 

instruments  for the loss of information? 
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Code Instrumentation 
•  Instrumentation is the thoughtful act of 

creating code that allows monitoring and 
measurement of execution to facilitate 
debugging and performance improvement 

•  Instrumentation provides: 
– Meaningful information about what, where, and 

why something is happening 
– Timing information in useful increments 
– Logs are a key tool used to provide 

instrumentation output 
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Instrumentation Advocates 
•  Two (among many) Oracle performance 

experts who advocate instrumentation: 
– Cary Millsap 

https://method-r/fogbuz.com/default.asp?W265 
– Tom Kyte

http://tkyte.blogspot.com/2005/06/
instrumentation.html 
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Tracking 
•  How do you know if your application is 

running properly? 
– Correctness of input/output processing 
– Execution speed within user targets 

•  When is the cost too high? 
– Tracking everything all the time provides 

mountains of not-very-useful data and can 
impede normal execution 

– Maybe; tracking should be “switchable” to be 
enabled when needed and disabled when not 
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Tuning 
•  What is acceptable performance? Have 

your users provided reachable targets? 
•  If something “takes too long” – it’s 

important to know where time is spent 
•  Instrumentation must provide meaningful 

information about when processes begin, 
when they end, and how long the activities 
being performed last 

•  Once problem areas are highlighted 
specific issues may be addressed 
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Instrumentation Strategies 
•  You need a strategy 

– Too little instrumentation; can’t use it 
– Too much instrumentation; masses of data that 

are hard to use 
– How will instrumentation take place? 

•  Home-grown? 
•  Using Oracle built-in facilities? 
•  Using vendor-provided facilities? 
•  some combination of the above? 
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Say “No” to System.out.println 
•  Many Java developers use console output 

via System.out.println for rudimentary 
instrumentation during testing 
– Production system consoles are often 

unmonitored 
– Production system consoles (today) are often 

part of a virtualized server; never to be seen… 
•  Instrumentation needs to survive the ups 

and downs of the JVM and be broadly 
available; logging provides many options 
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Logging 
•  You shouldn’t use online debug in production 
•  Traditionally, IT uses logging as a preferred 

method for collecting information about 
application effectiveness and efficiency 

•  ADF exists in the Java world where several 
logging tools are available including: 
– Java SE java.util.logging 
– Log4J 
– Apache Commons Logging 
– ADFLogger built into ADF 
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Planning for Logs 
•  Where will logs go? (console/XML/text/etc.) 
•  What level of Detail/Content? 

– Name of package & name of module 
– Name of method/procedure/function  
– Variable and parameter values in use at time 
– Applicable error messages/codes 

(Messages and/or codes?) 
– Date and time 
– Who will consume the log? Is translation 

needed? (user/admin/dba/support) 
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ADFLogger 
•  Oracle’s ADF team recognized the need for 

instrumentation and provided “ADFLogger”  
•  ADFLogger provides a log mechanism fully 

integrated with ADF via java.util.logging 
“under the covers” with added functionality 

•  ADFLogger works effectively both within 
JDeveloper and from Enterprise Manager 

•  ADFLogger may be switched on and off 
without restart 
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ADFLogger Levels 
•  Like most logging tools; ADFLogger divides 

log entries into several classifications: 
– SEVERE (fewest log entries) 
– WARNING 
–  INFO 
– CONFIG 
– FINE 
– FINER 
– FINEST (most log entries) 
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Useful ADFLogger Methods 
•  ADFLogger provides some methods of its 

own in addition to those inherited from 
java.util.logging; including: 
– begin() 
– end() 
–  log() 
– severe(), warning(), info(), config(), 

fine(), finer(), finest() 
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ADFLogger Complexity 
•  Several ADFLogger methods and 

constructors require HashMap input 
parameters 

•  It is probably simplest to create a utility 
method, interface and/or superclass class 
for your team rather than having everyone 
build basic logging logic themselves 
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ADF & WebLogic 
•  ADF is fully integrated into WebLogic; 

including ADFLogger and its tooling 
– A “logging.xml” file describe ADFLoggers, their 

default level, and the handlers used for them 
– JDeveloper has dialog-based configuration via 

“Oracle Diagnostics Logging Configuration” 
– JDeveloper also has “Oracle Diagnostic Log 

Analyzer” tool to review log output 
– Production support via Enterprise Manager  

(farm->WebLogicDomain->appcluster->YOURSERVER->logs) 
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JDeveloper Logging: 1 
•  First open Window->Application Servers if 

it is not already open 
(11g: View-> Application Server Navigator)  
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JDeveloper Logging, 2 
•  Next use IntegratedWebLogicServer’s 

context menu (right-click) and choose 
“Configure Oracle Diagnostics Logging” 
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JDeveloper Logging, 3 
•  ADFLogger is configured with “logging.xml” 

file; click the “source” tab to manipulate the 
XML or use the panel displayed  (preferred) 
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Add Custom Logger, 1 
•  To add your own logger click the green 

“plus sign” icon and choose whether to 
create a persistent or transient logger 
 
 
 
 
– Persistent logger   Stays after WebLogic 

     shutdown 
– Transient logger   Available until  

     WebLogic shutdown 
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Add Custom Logger, 2 
•  Name the logger; if you enter a Java class 

name the class name and its package 
name will be used to identify log entries 
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Add Custom Logger, 3 
•  You may also use a textual name; take 

time to plan what serves you best 
•  Choose the default level for messages 

associated with this logger 
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Adding Custom Logger, 4 
•  Custom logger(s) show in the configuration 

dialog with the Oracle-provided loggers 
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Enable Built-In Loggers 
•  Oracle has instrumented just about 

everything; probably too many choices 
•  A good base set is oracle.adf, 

oracle.adfinternal, and oracle.jbo (set level) 
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Step No Longer Needed? 
•  When using the built-in configuration tool; a 

runtime setting is automatically set; in 
earlier versions of ADF this required a 
restart of WebLogic (sometime still useful) 
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Built-In Log Analyzer, 1 
•  Use the “Tools” menu and select the 

“Oracle Diagnostic Log Analyzer” to open 
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Built-In Log Analyzer, 2 
•  Choose which loggers and levels to view: 
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Using Tracking Data, 1 
•  Select “By ADF Request” for details, times, 

and percentages 
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Using Tracking Data, 2 
•  Select “By Log Message” to see very 

detailed specifics 
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Using Tracking Data, 3 
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Save Logs to File 
•  Use JDeveloper’s preferences to save logs 

to a file in text form (probably increase 
maximum log lines, default is 300) 
JDeveloper->Preferences->Environment->Log 
(11g: Tools->Preferences->Environment->Log) 
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Log File Output 
•  ADF generates a text file that looks like: 
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SQL Statement Log 
•  Default oracle.jbo logging shows SQL 
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Custom Logging 
•  Here is some code added to view object 

implementation class when salary changes 
 

 private static ADFLogger myLogger = 
        ADFLogger.createADFLogger(EmpImpl.class); 
 
 public void setSal(BigDecimal value) { 
        myLogger.info("Salary for employee "  

       + this.getEmpno().toString() 
                      + " changed to "  

       + value.toString()); 
        setAttributeInternal(SAL, value); 
    } 
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Enable Custom Logging 
•  Use Oracle Diagnostics Logging Config. 
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Custom Logging Output 
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Related Output 
•  Use drop-down to select related output 
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Custom Timing Entries 
•  When the built-in instrumentation isn’t what 

you need; you can add timing yourself 
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Custom Timing, 2 
•  Checking if Logging enabled 
 
  public void executeQuery() { 
    Long startMillis = System.currentTimeMillis(); 
    Long endMillis = 0L; 
    Long elapsedMillis = 0L;  
    super.executeQuery();            
    if (myLogger.isLoggable(Level.INFO)) { 
        endMillis = System.currentTimeMillis(); 
        elapsedMillis = endMillis - startMillis; 
        myLogger.log("SQL execution ”+ elapsedMillis); 
        } 
    } 
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Enterprise Manager Support 
•  When executing in production environments; 

Enterprise Manager provides the ability to 
view WebLogic’s logging data: 
1.  Open the server farm 
2.  Select WebLogicDomain 
3.  Select appcluster 
4.  Choose the desired WebLogic server 
5.  Select logs to see options to turn logging  

on/off or to view logs 
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Use | Make | Buy 
•  Instrumentation is easy, we have 3 choices: 

– Use  Oracle’s built-in logging is vast and 
  provides great detail 

– Make  Use ADFLogger to “grow your own” 
(use superclasses to make it reusable) 

– Buy  Frank Houweling from Amis has created  
  an ADF Performance Monitor Tool 
  (I have not tested it thoroughly; but it  
  seems to work well) 
  More information is available at: 

http://www.amis.nl/ADFperformancemonitor 
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Wrapping it all Up 

•  Instrumentation is the key to debugging, 
tracking, and tuning ADF applications 

•  ADFLogger provides comprehensive 
logging ability “out of the box” 

•  JDeveloper provides GUI-based support for 
ADFLogger configuration and use 

•  Occasionally, it will be useful to create a 
“home-grown” ADFLogger; but, the built-in 
tools will work with that too   
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RMOUG Training Days 2016 
February 9-11, 2016 
(Tuesday-Thursday) 

Denver Convention Center 

R 
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Mandalay Bay  ���
Las Vegas, NV  

COLLABORATE 16 – IOUG 
Forum

April 10 – 14, 2016
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King Training Resources 
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Email: john@kingtraining.com 

Today’s slides are on the web: 
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Please Complete Session Evaluations 

Thanks for your attention! 
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•  End 
 


