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SQL Developer Tips for Everyone 

Presented by: John Jay King 
 

Download this paper from: http://www.kingtraining.com 
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Session Objectives 

•  Use Oracle SQL Developer to create, 
modify, and test SQL 

•  Discover the power of SQL Developer in 
creating and debugging PL/SQL 

•  Learn how SQL Developer makes creating, 
altering, deleting database objects easier 

•  Become aware of DBA tooling and reporting 
built into SQL Developer 

•  Model data using SQL Developer Data 
Modeler 
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Who Am I? 

•  John King – Partner, King Training Resources 

•  Oracle Ace Director 

•  Member Oak Table Network 

•  Providing training to Oracle and IT community for 
over 25 years – http://www.kingtraining.com 

•  “Techie” who knows Oracle, ADF, SQL, Java, and 
PL/SQL pretty well (along with many other topics) 

•  Member of AZORA, ODTUG, IOUG, and RMOUG 
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•  Providing customized training solutions since 
1988 in the US and internationally 

•  Oracle topics include: SQL, PL/SQL, Database, 
Cloud, APEX, ADF, MAF, Forms, Reports, Pro*C/
Pro*COBOL 

•  Non-Oracle topics include: UX, Web Services, 
IoT, Cloud Foundry, REST, Blockchain, Java, 
JavaScript, HTML5, CSS, jQuery, COBOL, .NET, 
SQL Server, DB2, Business Analyst, and more 

•  Visit us at www.kingtraining.com for more 
information and free downloads of presentations 
and code 

•  Contact Peggy at 1.303.798.5727 to schedule 
training today (email:                                       )  

King Training Resources 
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Arizona, USA 



6 
Copyright @ 2017, John Jay King http://www.kingtraining.com 

New SQL Developer 
•  Oracle SQL Developer 4.2 available; many 

new features & supports Oracle 12c  
•  Runs in Linux, Unix, MS Windows, and Mac OS x 

(requires Java SE JDK to run) 
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Getting SQL Developer 
•  Use Oracle.com “downloads” page 



8 
Copyright @ 2017, John Jay King http://www.kingtraining.com 

SQL Developer Start Page 
•  “Start Page” shown by default; note Tutorials 

and other options 



9 
Copyright @ 2017, John Jay King http://www.kingtraining.com 

Create Connection(s) 
•  SQL Developer can connect to just about 

anything with a JDBC connect string 
(works best with Oracle though…) 
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Connection Parameters 
•  Connection info must be provided 
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Connecting Via SSH, 1 
•  To connect to a database via SSH  

(e.g. DBaaS instance) you first define  
the SSH Host 

•  From SSH View (View->SSH from the SQL 
Developer menu)  
– Right-click and choose “New SSH Host”  
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Connecting Via SSH, 2 
•  Use information from instance to define a 

new SSH Host 
–  Name:  your choice 
–  Host: IP address 
–  Port: 22 
–  Username: oracle 
–  Check “Use key file” and browse to  

the private key file matching the  
database public key file 

–  Check “Add a Local Port Forward”  
and pick name, host, and port 

–  Click “OK” when done 
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Connecting Via SSH, 3 
•  Create connection to the instance (CDB): 

specify a username and password; choose 
Connection Type “SSH” and specify the 
Port Forward name from the previous step; 
use the SID (CDB) or Service Name (PDB) 
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Running SQL 
•  Click on connection     to open 

initial worksheet; right-click and “Open SQL 
Worksheet” for more worksheets 
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Write Your Own SQL 
•  You may enter SQL as desired, SQL 

Developer has many code-assist features 
 
 
 
 

•  Testing may be done in a few ways 
–        Run line(s); runs selected line(s) 
–        Run script(s); runs selected line(s) as a 

script – most SQL*Plus commands work here! 
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Query Builder 
•  Instead of writing/modifying SQL, use the 

Query Builder for graphic manipulation  
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Results from Run Line 
•  Run Line results in a formatted output 

window  
 
 
 
 
 
 
– Number of rows fetched is preference, number 

displayed only shows rows currently scrolled to 
– Results may be copied or exported elsewhere 
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Result from Run Script 
•  Run Script results in output that looks like 

that from SQL*Plus (formatting too) 
 
 
 
 
 
 
 
– SET ECHO ON to include SQL with output
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Multiple Command Scripts 
•  Run multiple PL/SQL, SQL, SQL*Plus scripts; 

delimit with semi-colons & “Run Script” 



20 
Copyright @ 2017, John Jay King http://www.kingtraining.com 

Errors 
•  SQL Developer shows errors when needed 

 
 
 
 
 
 
 
– Error messages include line number and column 
– Display line numbers; right-click in gutter then 

“Toggle Line Numbers” or set in preferences 
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Seeing DBMS_OUTPUT 
•  Many PL/SQL scripts use DBMS_OUTPUT 

as a debug aid; turn on using  
View->DBMS_OUTPUT then choose user 
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SQL Developer & Explain 
•  Click the “Explain” icon to get SQL plan 
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SQL Developer AutoTrace 
•  Click “AutoTrace” icon to show trace data 
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AutoTrace Testing 
•  Use the AutoTrace context menu to 

experiment with alternate plans via hints 
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Formatting 
•  Formatting is managed in 

preferences 
•  Right click in the SQL  

Worksheet and choose  
option “Format” 
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Code Outline 
•  Choose “Code Outline” from the context 

window to see what the parser sees 
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Preferences 
•  SQL Developer has many preference options 

 
 
– Font 
– History 
– Colors 
– Code-Assist 
– More…     
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Controlling Auto-Editing 
•  Use the preferences panel to manage the 

“automatic” editing SQL Developer features 
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Code Templates 
•  Use Preferences to use existing code 

templates and to create custom templates 
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Object Display/Manipulation 
•  Use the Object navigator to view objects 

belonging to the current connection’s id or 
others – preferences may be used to limit 
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Object Manipulation 
•  The object display has many options 

including: 
– Right click to generate DDL for objects via the 

context menu 
– Double-click to work with a specific object 
– Drag and drop objects between connections, 

even remote connections 
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Table Display 
•  View/Modify database objects easily 
•   

 
 
 
 
 
 
– ALL_ system catalog information available in a 

few simple tabs (Columns, Data, Constraints, 
etc.); click SQL to create/see DDL for object 
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Create/Alter/Drop Objects 
•  From the Object Navigator display objects 

may be created, altered, and dropped; data 
may also be imported/exported 
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Drag & Drop Object 
•  Objects may be dragged and dropped from 

one connection to another 
– Tables, Indexes, and triggers 
– From SQL Server to Oracle  

(but not the other way) 
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Create PL/SQL 
•  Right-click on Procedures, Functions, 

Packages to build new PL/SQL object 
– Provide name and (optionally) parameters 
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Modify & Test PL/SQL 
•  Type code then use provided icons to 

Compile, Run, Debug, or Profile 
(respectively) 
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Tool Provides Test Scripts 
•  When you click “Run” or “Debug” SQL 

Developer will provide a test script 
 
 
 
 
 
 
 
 
– Set variables as needed and click “OK” to run 
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Debugging PL/SQL 
•  SQL Developer’s PL/SQL debugger allows 

all of the things you expect in a debugger 
 
 

•   
 
 
– Setting/removing breakpoints 
– Conditional breakpointing 
– Stop/Resume execution 
– Modify and “Watch” variables 
– more… 
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Versioning 
•  SQL Developer is prepared to help you in 

versioning and continuous integration 
•  Subversion and Git capabilities are built in 
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Other Programming Aids 
•  In addition to Subversion and/or Git;  

SQL Developer also supports: 
– Maven 
– Hudson 
– Unit Testing 
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SQL Developer & DBAs 
•  SQL Developer has many features 

designed to help DBAs get their jobs done 
– Manage Database and other tools provide DBA 

features 
– DBA View includes many DBA features 

•  SQL Developer will display a caution pop-
up before allowing use of features requiring 
addition licensing 

•  This is not a replacement for Enterprise 
Manager but may allow you to perform 
many similar functions simply & quickly 
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Manage Database, 1 
•  Use the connection context-menu option 

“Manage Database” 
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Manage Database, 2 
•  The “Manage Database” display provides 

lots of useful high-level data 
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DBA View 
•  Use View->DBA from the menu to display 

 
 
 
 
 
 
 
 

•  Be sure NOT to use features unless you 
have licenses (may limit in preferences) 
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Database Preferences 
•  Use Preferences->Database->Licensing 

page to control use of licensed features 
(use only features your organization has 
licensed) 
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Database Status 
•  From the DBA view Select Database 

Status-> Status to see non-graphic display  
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DBA Instance Viewer 
•  From the DBA view Select Database 

Status-> Instance Viewer to see a  
graph of  
instance  
health,  
including 
Top SQL 
 
 

– Click on graphics to see specific details 
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Instance Top SQL 
•  Double click on instance graph’s Top SQL 

to see Top SQL; click on an individual SQL 
to get its details 
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Top SQL Details 
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Licensing Warning 
•  Attempting to use features requiring special 

licensing will display a warning 
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DBA Tasks 
•  Many DBA tasks may be performed  

including Tablespace maintenance 
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Database Configuration 
•  Use DBA View to view/change configuration 
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Configuration Changes 
•  Double-click an option, then click the 

“pencil” icon to change a parameter 
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Data Pump 
•  Data Pump may be managed as well 
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Other DBA View Options 
•  The DBA offers many  

other options, some  
require licensing some  
do not 
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12c Multi-Tenant Features 
•  The DBA View connection context menu 

offers some multi-tenant features 
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SQL Developer DBA “Tools” 
•  The SQL Developer “Tools”  

menu offers DBA features 
– Database Copy 
– Database Diff 
– Database Export 
– Migration 
– Monitor Sessions 
– Real Time SQL Monitor 
– REST Data Services 
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Data Modeling 
•  SQL Developer has  

excellent Data Modeling  
built right in; or, you can 
also download/install  
Data Modeling separately 

•  File->Data Modeler 
-> Export 
-> Data Dictionary 
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Data Modeling Support 
•  Both Edit and View menus provide support 
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Model Existing 
•  Drag & Drop existing tables into model 
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Data Model From Scratch 
•  Data Modeler lets you start from scratch 
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Built-In Reports 
•  SQL Developer has many built-in reports to 

reduce your repetitive effort 
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User-Defined Reports 
•  You can create your own reports based 

upon your own SQL (may include bind vars) 
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Migration Tools 
•  SQL Developer provides migration tools 

from “other” database tools to Oracle 
 
 

•  Migration paths built-in include: 
– Microsoft SQL Server (and TSQL!) 
– Teradata 
– MySQL 
–  IBM DB2 
– Microsoft Access 
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Back to the Command Line 
•  Now for something really different... 

– Oracle now provides the Oracle SQL 
Developer Command Line interface (SQLcl) 

– Today downloaded separately, part of “normal” 
install soon 

– Requires pre-installed Java 8 (or higher) JRE 
– Allows all SQL*Plus commands plus more 

without requiring Oracle client 
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SQLcl Looks like SQL*Plus 
•  SQLcl is a Java app; no Oracle client needed 
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SQLcl Improves SQL*Plus 
•  The team that created SQLcl created a 

newer, better SQL*Plus with JavaScript 
– Many new commands 
–  Improved Editing 
– Code completion 
– More… 
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SQLcl New Commands 
•  Help lists original SQL*Plus commands 

plus new SQLcl commands (underlined) 
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Coming Soon... 
•  Sometime soon SQL Developer will be 

available as a browser-based application 
– No software required on client machine other 

than the browser 
– Full SQL Developer functionality  

(at least that’s the plan) 
–  Improved graphics with HTML5 
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Wrapping it all Up 

•  Oracle’s SQL Developer tool is an excellent GUI 
for writing and managing SQL and PL/SQL 

•  SQL Developer’s PL/SQL Debugger provides the 
type of support expected of world-class IDEs 

•  SQL Developer also provides Data Modeling and 
DBA support 

•  Did I mention that SQL Modeler is FREE??? 
•  Download from Oracle’s OTN: 

http://www.oracle.com/technetwork/indexes/downloads/
index.html#tools 
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RMOUG Training Days 2018 
February 20-22, 2018  (Tuesday-Thursday) 

 Westin Hotel 
10600 Westminster Blvd 
Westminster, CO 80020 

R 
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collaborate.ioug.org 
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Kscope 2018 in Orlando! 
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SQL Developer Tips for Everyone 
 
To contact the author: 
John King 
King Training Resources 
P. O. Box 1780 
Scottsdale, AZ  85252   USA 
1.800.252.0652 - 1.303.798.5727 
Email: john@kingtraining.com 
Twitter: royaltwit 

Today’s slides and examples are on the web: 
http://www.kingtraining.com 

Please Complete Session Evaluations 

Thanks for your attention! 
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•  End 
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ORDS Installation 
•  Installation is easy with SQL Developer 
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ORDS Setup Steps 
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ORDS Installed 
•  After several wizard-based steps 

installation is complete 
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ORDS Administration 
•  SQL Developer provides an Administration 

capability for ORDS 



80 
Copyright @ 2017, John Jay King http://www.kingtraining.com 

ORDS Reporting 
•  SQL Developer has reporting built-in 
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Enable ORDS for Table 
•  Right-click on a table to enable ORDS 

using a wizard-based process 
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Manual ORDS 
•  Use SQL Developer wizards to map ORDS 

for SQL and PL/SQL 
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PL/SQL ORDS APIs 
•  Oracle provides a PL/SQL package that 

allows creation and manipulation of ORDS 
in code 

•  Complete PL/SQL API for defining and 
configuring RESTful services 
– May be put into scripts 
– May be repeated 
 
https://docs.oracle.com/cd/ 
  E56351_01/doc.30/e56293/ 
  ords_ref.htm#AELIG90180 


